WP5.5后如何平稳度过jQuery兼容问题

WP5.5后如何平稳度过jQuery兼容问题

随着WordPress 5.5的更新,默认情况下不再启用称为jquery-migrate的迁移工具。 这可能会导致某些主题或运行较旧代码的插件缺少功能或出现意外行为。
该插件用作临时解决方案,使您网站的迁移脚本能够为您的插件和主题作者提供更多的时间来更新和测试其代码。
随着WordPress 5.6的更新,包含的jQuery版本也已升级。 这意味着以前引起警告的旧代码现在可能会导致错误或完全停止工作。
一些不再起作用的功能将在幕后停止工作,而没有任何明显的问题。
该插件可以让您在一段时间内降级到jQuery的早期版本,但是作为站点管理员,我们建议您修复潜在的问题。Enable jQuery Migrate Helper

这个插件会在后台反复显示侦测到的jQuery兼容性问题,可以用Disable Admin Notices Individually插件隐藏。

整个WordPress主题与插件生态要完全脱离旧版jQuery(以及migrate)过度到新版jQuery库(3.5+)估计还需要较长时间。

习惯了React/Vue语境的程序员读者,是的,jQuery没死,它仍运行在全世界38%+的网站上。

声明:本站带有” 原 “字文章,均为本站作者原创发布。原创文章任何个人或组织,在未征得本站同意时,禁止复制、盗用、采集、发布本站内容到任何网站、书籍等各类媒体平台。如若本站作者内容侵犯了原著者的合法权益,可联系我们进行处理。

文章来源 segmentfault https://segmentfault.com/a/1190000038682294

上一篇:

已经没有上一篇了!

相关文章

官方客服团队

为您解决烦忧 - 24小时在线 专业服务

  • 软件商用保障
    正版采购,正规版权
  • 终身SVIP
    一次购买,终身受益
  • 海量资源
    教程、主题、插件一应俱全
  • 高效学习
    多位资深大佬,坐台解答
  • 信用保证
    数百万站长和用户的选择